Multiple VLAN's and bridge solution

First of all, I'm not sure if this is even possible, but I sure hope so it is :)
I've been trying a few different configs, but it still doesn't work, which is why I'm posting this with the current configuration I'm running with now.

The setup I'm trying to get to work is as follows: Backbone---Switch1---1242 root access point---1242 workgroup bridge---switch2---1 PC and 2 cameras.
The thing is, I have two VLAN's on switch1 (One for users, and one for cameras), which I'm trying to get to switch2 via two access points.

ROOT_AP#sh run
Building configuration...

Current configuration : 2977 bytes
!
! Last configuration change at 12:09:01 MST Mon May 30 2011 by cISCO
! NVRAM config last updated at 12:23:59 MST Fri May 27 2011 by Cisco
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ROOT_AP
!
enable secret 5 $1$6O05$tDBICf.zFMBuK3JttSh2c0
!
no aaa new-model
!
!
!
dot11 ssid XXX
vlan 45
authentication open
mbssid guest-mode
!
dot11 ssid XXX
vlan 1
authentication open
mbssid guest-mode
infrastructure-ssid
!
dot11 network-map
power inline negotiation prestandard source
!
!
username Cisco password 7 05280F1C2243
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 1 key 1 size 128bit 7 XXXXXXXXXXXXXXXXXXXXXXXXXXXX transmit-key
encryption vlan 1 mode ciphers tkip wep128
!
encryption vlan 45 key 1 size 128bit 7 XXXXXXXXXXXXXXXXXXXXXXXXXXXX transmit-key
encryption vlan 45 mode ciphers tkip wep128
!
ssid XXX
!
ssid XXX
!
speed basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
channel 2437
station-role root access-point
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.45
encapsulation dot1Q 45
no ip route-cache
bridge-group 45
bridge-group 45 subscriber-loop-control
bridge-group 45 block-unknown-source
no bridge-group 45 source-learning
no bridge-group 45 unicast-flooding
bridge-group 45 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
shutdown
no dfs band block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
ip address 172.25.41.16 255.255.254.0
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
!
interface FastEthernet0.45
encapsulation dot1Q 45
no ip route-cache
bridge-group 45
no bridge-group 45 source-learning
!
interface BVI1
ip address 172.25.41.16 255.255.254.0
no ip route-cache
!
ip default-gateway 172.25.40.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/sm ... g/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
!
end

ROOT_AP#




WGB_AP#sh run
Building configuration...

Current configuration : 2977 bytes
!
! Last configuration change at 12:09:01 MST Mon May 30 2011 by cISCO
! NVRAM config last updated at 12:23:59 MST Fri May 27 2011 by Cisco
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname WGB_AP
!
enable secret 5 $1$6O05$tDBICf.zFMBuK3JttSh2c0
!
no aaa new-model
!
!
!
dot11 ssid XXX
vlan 45
authentication open
mbssid guest-mode
!
dot11 ssid XXX
vlan 1
authentication open
mbssid guest-mode
infrastructure-ssid
!
dot11 network-map
power inline negotiation prestandard source
!
!
username Cisco password 7 05280F1C2243
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 1 key 1 size 128bit 7 XXXXXXXXXXXXXXXXXXXXXXXXXXXX transmit-key
encryption vlan 1 mode ciphers tkip wep128
!
encryption vlan 45 key 1 size 128bit 7 XXXXXXXXXXXXXXXXXXXXXXXXXXXX transmit-key
encryption vlan 45 mode ciphers tkip wep128
!
ssid XXX
!
ssid XXX
!
speed basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
mobile station 2437
station-role workgroup-bridge
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.45
encapsulation dot1Q 45
no ip route-cache
bridge-group 45
bridge-group 45 subscriber-loop-control
bridge-group 45 block-unknown-source
no bridge-group 45 source-learning
no bridge-group 45 unicast-flooding
bridge-group 45 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
shutdown
no dfs band block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
ip address 172.25.41.17 255.255.254.0
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
!
interface FastEthernet0.45
encapsulation dot1Q 45
no ip route-cache
bridge-group 45
no bridge-group 45 source-learning
!
interface BVI1
ip address 172.25.41.17 255.255.254.0
no ip route-cache
!
ip default-gateway 172.25.40.1
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/sm ... g/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
!
end

WGB_AP#

Thanks in advance!
Komentar →
Comments
0 Comments

0 comments:

Posting Komentar

komentar anda sangat penting utk kemajuan blog ini.trimakasih utk kunjungannya...

◄ Posting Baru Posting Lama ►
 

tourist n stats

W3 Directory - the World Wide Web Directory My Ping in TotalPing.com
Google PageRank Checker Powered by  MyPagerank.Net

guest room

Copyright © 2012. CYBER MANADO - All Rights Reserved B-Seo Versi 3 by Bamz